signature on mac



i have a question about signature on mac:
when i start it on my terminal, everything seems to work fine....except the menus. with micrograph/template/particle
buttons i can change between the screens, all the dialogs are fine, but when trying to choose any option from the menu,
it's simply non-clickable. also, the app looks permanently in the background. what can i do, to make it work ?



Hi JP, I just repeated your issue on my laptop (Intel macbook pro 2006, Leopard 10.5.8). I tried recompiling Signature from the web distribution without any luck. This will need attention from whoever did the mac compile... I will ask James Chen (author) when I see him, hopefully tomorrow.


The OS X build of Signature available for download is built for the PowerPC architecture.

It kinda runs under Rosetta on 10.5, but it's not usable as you point out.

It doesn't run at all under 10.6.

I tried building from source, but it failed during the 'make' phase. I didn't investigate any past that. Presumably it would compile if the appropriate amount of effort was applied.


James Chen has fixed the problem and we have posted updated versions of Signature on the web page. Please let us know if they work on your systems.